Black particles appears transparent after render pass

Hi! (~again :point_right: :point_left:)

I’m racking my brain on this and can’t figure it out. I have some black particles that appear as transparent when integrated to the scene using the render pass, is there any way to stop this from happening? maybe a different blend mode.

Actually the only thing that really need the render pass are the first two elements (LightSide and DarkSide) but I supposed that I had to add the rest of the elements using the same render pass because they are left out of the scene (Is there any way to avoid this?).

Thanks in advance!

You could try switching the order of that last blend patch. The destination is the bottom layer and source is the top. But… if you are adding a black particle, it probably won’t show up because adding 0 (black) to something else, doesn’t do anything. Try setting the default color to transparent and then play with the blend modes.

Otherwise, you can try using render tags to render the particles directly in your other two render passes.

2 Likes

Thanks a lot! RenderTags did the work (Didn’t know about it).

For posterity,this is how it turned out:

2 Likes