Delay frame patch whitescreen output

I’m trying to use the Delay Frame Render Patch (Shader Render Pass Patch) but a whitescreen appears instead of preview. Am I doing something wrong?

This is my PE:


It looks the same that the example one :frowning:

Can anybody help me with this?

Thanks in advance!

It must work. What did the shader preview show? Do you have something in your Scene?

1 Like

Troubleshooting suggestion:
Did you copy paste the receiver? Have you checked the receiver to make sure that it receives from the right sender?
Because there is this problem that if you just copy paste a receiver, the name is the same, but actually it doesn’t receive any signal until you reassign it.

Do you have scene render pass in your project?
Is this project an old project that you open in newer spark ar version?
My experience from the previous version, there is this annoying bug where after some action makes render pass patches broken, so we have to replace it with a new one that we put in manually again. (not copy paste)

if after you tried it and it is still not working, i have no idea what could be the main problem.

4 Likes

Thanks both of you!

Adi, you were right! when I copied the Receiver it had “Delay frame” in its name but the sender was not correctly setted

I’m not sure if the Spark devs are aware of this issue. It’s been around forever and it’s hard to solve even if you know it’s an issue! If you submit a bug report (little bug icon in the lower left), that will help get it fixed sooner.

I’ve reported it as a bug and when I made a post to the Spark FB group about it others said they had as well… but it continues to “get” users again and again

1 Like

It gets ME consistently. At this point I only spend a few minutes finding the bug in my own projects, but it’s WAY more time consuming to find the bug in a coworker’s file. Thanks for reporting :smiley:

2 Likes