Face Tracker Plane isn't visible? Help

Hello everyone!

Hope everyone is having a good day. I recently built a filter with a camera effect over it but i’d also like to add a plane tracker on top of it (a company slogan texture image). I added in my Facetracker > Plane > add Material and it shows up on my preview screen (the development grid) but it doesn’t appear on a preview of the filter (mockup screen with my face). I am not sure why this is happening and I don’t know how to fix it.

If anyone has any has any solutions it would be very helpful. I am open all suggestions.

Thanks so much!

Try playing with the advanced render settings on your materials. For most cases, unchecking the depth options will fix this.

1 Like

Hey Josh,

Thanks so much for suggesting this but un-checking the depth did not work for me. I still see the plane texture on my mockup screen but not on my filter.

Do you have any other suggestions? I would really really appreciate any help you can offer! :slight_smile:

Thank you so much

UPDATE: When I remove my halftone effect. The Face Tracking texture )the logo i’d like to add) shows up. So something with the halftone effect it making it stop working but I need that halftone effect in or else I can’t use this filter. Are there ways that I can keep both my logo and my halftone effect?

Did you uncheck the depth on the plane material? I think that should do it. You could also try assigning layers but I usually don’t have much luck with that.

1 Like

Hey Josh!

Thanks for being super helpful with my question. I really appriciate you taking the time out of your day to help me out. I did uncheck the depth box but i’m unsure if it helped. I attached a photo of my screen for you to reference. I am still quite new to this so I might be looking at the wrong depth box you are referring too.

  • Connie

Oh, I see now! You are using render pass, which means you need to render scene objects manually. I conveniently wrote up an example for someone else recently!

Basically, you need to use scene render pass and blend it on top of the hearts

2 Likes

Thank you Josh! You are a serious Spark AR guru!

1 Like