OVR controller buttons not working

While working on a game with @finofinissimo, OVRInput.GetDown was suddenly not picking up any events for our controllers, which totally broke the game. What’s crazy is that the controllers worked fine in some scenes, and everything worked normally in the build. In the editor, I couldn’t get any button events to fire.

I did eventually find a solution on the unity dev forum, but it was buried in the second page.

The problem was that we were calling OVRInput.Update() multiple times in different modules. It was incredibly frustrating to debug, and there’s no error message telling you that something went wrong. If this is going to totally break entire projects, I hope they’ll add some kind of throttler that prevents multiple calls to the update function. Maybe it could be renamed to RequestUpdate() so that multiple modules could call it without needing to know if it was used elsewhere.

2 Likes

The directions provided on Oculus documentation can lead to a lot of crazy stuff.