Patch assets (.arp files) won't appear in Spark Studio project

in the past I have encountered this same situation where I import a .arp patch asset file (by dragging it directly into the Assets panel or by going through the Import/From Computer process) into the Assets for a project but the imported patch asset does not appear there. In the past I’ve always been able to quit/relaunch and maybe reimport and get it to work but this time it’s still not working. (quickly testing it on a newly created project it seems to work fine) Even though it doesn’t appear in the Assets Panel of my current project I can actually see that a copy of the .arp file is getting written to the Patches folder for that project. But I can also see that Spark Studio doesn’t see the import as an unsaved change… :frowning: (no asterisk in the title bar next to the project name) Originally I was trying to copy/paste the patch group from another project into the current one but THAT wasn’t working either so I tried the Patch Asset route but NO… I’ve tried various patch assets as a test but none of them will appear so the issue is with the project not the patch asset… Anyone have any clever workarounds for this annoying behavior in Meta Spark Studio ?

actually I had thought the problem went away but it did not - some patch assets appear while some do not, perhaps the assets created with more recent versions of Spark Studio do not… (I believe there’s a new readable (XML?) format being used behind the scenes now… maybe it broke the patch asset workflow

here is the bug (no good workaround as far as I know), reported it through the app

Spark Studio projects created with an older version will not display Patch Assets created with a newer version

  • open the attached zip archive

  • inside are the following items

  • import_patch_asset_OLD.arproj

  • import_patch_asset_NEW.arproj

  • test_patch_asset_NEW.arp

  • RGB Shift Shader.arp

  • the projects are entirely empty default projects, and both have been resaved in the current version of Spark Studio, although the “OLD” project was created with some previous Spark Studio version (not sure exactly which version)

  • open both projects in the current version of Spark AR Studio

  • import the RGB Shift Shader.arp into both projects

  • see how the RGB shift asset appears in both projects as expected (it was created with an older version of Spark Studio)

  • now import the test_patch_asset_NEW.arp into both projects

  • see how the patch asset created with a newer version of Spark Studio appears as expected in the “NEW” project but does not appear in the “OLD” project

  • you might notice that for the “OLD” project, a copy of the “NEW” patch asset has been added to the “Patches” folder for that project, but Spark Studio doesn’t seem to recognize the import as an unsaved change (no asterisk on the title bar next to the project name) and the asset is never displayed in the project

  • I also find that it does not seem to be possible to copy a patch created in the NEW version and paste it into an OLD project (probably for the same reason - whatever it is…)

  • As far as I know there is no way to update the “OLD” project so it can display the “NEW” patch assets (which I expect will be kind of a problem for a lot of long time creators as more assets are created with the new version)