Slo Mo/ Delay on Objects in Lens Studio

Hi Everyone,
I have been playing with Lens a bit lately and discovered that when you set the Render Target in the Resources panel to ‘none’ you get this really cool effect!
I have been trying to figure out how to get this effect onto just a specific object without loosing the rest of the scene.
I tried to add a additional ‘Render Target 2’ and another camera with it’s ‘Render Target’ set to ‘Render Target 2’ + added the object into that camera and placed it on different layers etc. The outcome is always the same. (black BG and all the 3D objects have the effect)

So here the question: Any idea how to set this effect on a single 3D object and not affect the rest of the scene?

Thank you!
"Cool Effect" I am talking about:

![slo mo flower|277x500]

The ‘normal’ look. I would like to have the ‘Cool Effect’ happening only on the flowers.

!

I checked out this tutorial, seemed like a hint to where I want to go but not sure :smiley:

1 Like

I have done this before, but didn’t really wrap my mind around how it’s working. The camera system and render targets are still weird to me. Here’s the tutorial I followed from the legendary Ben Knutson

2 Likes

so what you can try doing is create a new camera and render target with the setting and make that object alone under the camera . and them it will work so if its layers make sure the camera only renders that layers and not other layers and the one more main thing is move the camera to the side because most of the time all the camera will point towards the same object so move the camera in x axis so its not pointing to elements of other camera

hi @rbkavin !
thank you for your reply! I tried to follow your instructions but I am not 100% sure I understand what you mean.
Here is the scene:
I have two cameras on different layers (‘Camera’ on blue and ‘Camera 2’ on yellow). Each camera has a different render target ‘(Render Target’ on ‘Camera’ and and’ Render Target 2’ on ‘Camera 2’).

I want the ‘Face Mesh’ in ‘Camera 2’ to be Slo mo while the ‘Face Mesh’ in ‘Camera’ remains normal.
I also moved ‘Camera 2’ slightly on the X axis.


Thanks a lot!

  • you have to move the camera 2 more in the x axis because the 3d models of other camera will also be visible in the other camera as they share common world position . Mostly in ur case it might not happens due to layer but u can move it so the cameras view field don’t overlay on each other .

  • then you can do the setting you want to the render target

  • then using a screen images what u can do is apply the render target as a texture and there u can combine both camera render target

1 Like