Topology issue in advanced render mode (Write to Depth Buffer and Use Depth Test off )

This is something I came across while doing the project. The torus topology objects are see-through in advanced render-mode. My current workaround is to have two meshes with two identical materials, one that has advanced render checkboxes on and one-off. Did anyone faced this issue?

topology issue

I think you should only disable those depth render options for flat objects. If you use it on 3d objects you will almost certainly get some weird stuff like this happening. If you need these objects to show on top of others, you could use the layers, but TBH that stuff isn’t too reliable for me. The other option would be to use scene render pass and blend together the layers as you need.

1 Like